1С создать документ программно и открыть форму

В 1С Предприятии 8.2 для этих целей существует два возможных сценария работы:

  • открыть форму нового документа и предоставить пользователю самому интерактивно записать данные объекта в базу данных.
  • создать новый документ программно, программно заполнить его данными и программно записать. Затем, если нужно, показать его пользователю.

В первом сценарии проще всего использовать метод глобального контекста ОткрытьФорму() . Это можно сделать на клиенте.

При этом создается новый документ и открывается для редактирования основная форма этого документа.

Если нужно какое-то предварительное заполнение документа начальными данными, то это можно сделать либо с помощью свойств реквизитов документа ЗначениеЗаполнения , ЗаполнятьИзДанныхЗаполнения либо в обработчике события документа ОбработкаЗаполнения . Подробнее об этом событии можно посмотреть в вопросе Как при открытии формы определить, что создается новый элемент?.

Во втором случае можно программно создать документ на сервере, заполнить данными, если это нужно в обработчике события ОбработкаЗаполнения , записать, и передать ссылку на новый документ в метод глобального контекста ОткрытьЗначение() , который откроет форму этого документа. Например:

Подробнее об использовании методов ОткрытьЗначение() и ОткрытьФорму() можно прочитать в синтакс-помощнике: Глобальный контекст — Процедуры и функции для интерактивной работы .

Программное открытие форм в управляемом приложении 1С значительно отличается от их открытия в обычном приложении. Рассмотрим для начала старый метод. Он заключается в получении формы и ее последующем открытии в обычном или модальном режиме (при открытии в модальном режиме форма блокирует работу программы).

Это самый медленный метод открытия форм. Тем не менее, он позволяет программно обработать форму перед открытием. Для обработки код нужно немного изменить:

Надо учитывать, что при получении формы будет выполняться еще процедура события ПриСозданииНаСервере.

Рассмотрим другие методы, которые позволяют открывать формы в управляемом приложении 1С быстрее и удобнее. В зависимости от конкретной ситуации могут использоваться разные методы.

Читайте также:  Как заряжать айфон через компьютер

1. Как открыть форму объекта в управляемом приложении, если есть ссылка на него.

В этом случае все предельно просто.

2. Как открыть форму выбора и получить потом выбранное значение.

Для этого существует функция ВвестиЗначение(). У функции 3 параметра:

  • Переменная, в которую будет записано выбранное значение;
  • Подсказка, которая будет отображена в окне выбора;
  • Описание типов выбираемых значений. Может быть несколько типов, тогда перед выбором конкретного значения будет предложено выбрать тип.

В результате выполнения функции откроется форма выбора по умолчанию для объекта указанного типа.

Перем Значение ;
Массив = новый массив ;
Массив . Добавить ( Тип ( "СправочникСсылка.Номенклатура" ) ) ;
Массив . Добавить ( Тип ( "СправочникСсылка.Контрагенты" ) ) ;

ОписаниеТипов = новый ОписаниеТипов ( Массив ) ;

Рез = ВвестиЗначение ( Значение , "Подсказка" , ОписаниеТипов ) ;

Предыдущие способы позволяли открывать только формы, установленные для объектов по умолчанию (форму объекта или форму выбора). Если нужно открыть произвольную форму, то можно воспользоваться функцией ОткрытьФорму().

Эта функция имеет довольно много параметров. Рассмотрим некоторые из них:

  • Имя формы — тут можно выбрать либо одну из стандартных форм объекта, например, ФормаВыбора или ФормаСписка. Или конкретную, созданную разработчиками форму.
  • Параметры — позволяет передать в форму в виде структуры некоторые параметры перед ее открытием, тем самым определив выводимые данные. Параметры могут представлять собой любые данные, которые можно передавать с клиента на сервер. Переданные при открытии формы параметры можно обработать в процедуре ПриСозданииНаСервере() у открываемой формы.
  • Режим открытия формы — имеет 3 варианта: независимый, блокировать весь интерфейс, блокировать форму владельца.

Рассмотрим, как применяется функция ОткрытьФорму() в различных ситуациях.

3. Как открыть форму существующего объекта

У каждой формы есть один ключевой реквизит. Он выделен жирным в списке реквизитов формы и обычно называется Объект у форм элементов справочников, документов. У других объектов название может быть другим. Для открытия формы существующего объекта нужно передать в открываемую форму параметр Ключ со значением в виде ссылки на объект.

Читайте также:  Топ комнатных антенн для телевизора

&НаКлиенте
Процедура Команда 1 ( Команда )
Параметр = новый структура ;
Параметр . Вставить ( "Ключ" , НайтиС ( ) ) ;
ОткрытьФорму ( "Справочник.Контрагенты.ФормаОбъекта" , Параметр ) ;
КонецПроцедуры

&НаСервере
Функция НайтиС ( ) ;
Возврат Справочники . Контрагенты . НайтиПоРеквизиту ( "ИНН" , "745107734623" )
КонецФункции

4. Как открыть форму нового объекта

Тут подойдет просто функция ОткрытьФорму() без всяких параметров.

5. Как открыть форму нового объекта и заполнить ее на основании чего-либо

Нужно передать параметр Основание, значением которого будет являться ссылка на объект-основание заполнения. При этом будет запущена процедура ОбработкаЗаполнения().

В этом примере будет создан документ Реализация товаров и услуг и заполнен на основании счета на оплату покупателю, ссылка на который была передана.

6. Как открыть форму и задать на ней отбор

Отбор на формах 1С может быть простым и сложным. Простой отбор предусматривает выражения типа Организация = ООО «Рога и копыта». Сложный отбор предполагает и другие типы сравнения, например, В списке. В данной статье рассмотрим организацию простого отбора, а сложному будет посвящена отдельная статья.

Чтобы организовать простой отбор, нужно передать в открываемую форму параметр с ключом Отбор, значением будет являться структура, в которой ключ — имя поля динамического списка, а значение — искомые данные.

Например, откроем форму списка справочника НомераГТД и сделаем там отбор по владельцу — элементу справочника Номенклатура.

Отбор = новый Структура ;
Отбор . Вставить ( "Владелец" , СсылкаНаНоменклатуру ) ;

Параметр . Вставить ( "Отбор" , Отбор ) ;

ОткрытьФорму ( "Справочник.НомераГТД.ФормаСписка" , Параметр ) ;
КонецПроцедуры

7. Как открыть форму записи регистра сведений

Для этого понадобится ключ записи регистра сведений.

Ключ записи — это значения всех измерений и период (если регистр периодический). То есть ключ записи — это параметры, по которым можно однозначно идентифицировать запись.

Алгоритм открытия следующий:

  1. Заносим в структуру данные ключа записи с необходимыми значениями.
  2. Помещаем полученную структуру в массив.
  3. Из массива создаем ключ записи.
  4. Передаем в открываемую форму параметр Ключ с ключом записи из п.3 в качестве значения.

ПараметрыКлюча = новый Структура ;
ПараметрыКлюча . Вставить ( "Номенклатура" , СсылкаНаНоменклатуру ) ;
ПараметрыКлюча . Вставить ( "ТипЦены" , СсылкаНаТипЦен ) ;
ПараметрыКлюча . Вставить ( "Период" , Дата ) ;

МассивКлюча = Новый Массив ;
МассивКлюча . Добавить ( ПараметрыКлюча ) ;

Читайте также:  Прошивка htc quietly brilliant

КлючЗаписи = Новый ( "РегистрСведенийКлючЗаписи.ЦеныНоменклатуры" , МассивКлюча ) ;

Параметр . Вставить ( "Ключ" , КлючЗаписи ) ;

ОткрытьФорму ( "РегистрСведений.ЦеныНоменклатуры.ФормаЗаписи" , Параметр ) ;
КонецПроцедуры

Итак вопрос №1: Как открыть форму еще не записанного документа (не заполнить на основании) ?

Ответ: Чтобы открыть форму нам нужно связать ее с ссылкой объекта, но объект еще не записан. Многие пытаются использовать метод УстановитьСсылкуНового() но это не прокатывает. После долгих чтений я сделал вот так:

&НаКлиенте
Процедура Команда(Команда)

Форма = ПолучитьФорму(«Документ.НашДокумент.ФормаОбъекта»);
ДанныеФормы = Форма.Объект; // Получаем объект формы в переменную
ЗаполнитьДокументНаСервере(ДанныеФормы); // Заполняем документ на сервере
КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); // копируем наш объект в объект формы и далее открываем ее
Форма.Открыть();

// Можно использовать безконтекстный вызов, оптимизируем передачу данных

Док = ДанныеФормыВЗначение(ДанныеФормы, Тип(«ДокументОбъект.НашДокумент»)); // Получаем объект из данных формы ИЛИ

// Заполняем реквизиты объекта или другие действия ********

ЗначениеВДанныеФормы(Док,ДанныеФормы); // Кладем обратно в объект формы уже созданный документ

2. Как открыть форму уже записанного документа?

Здесь есть два метода ОткрытьФорму() или ОткрытьЗначение(). В обоих случаях нужно передавать ссылку на записанный документ.

&НаКлиенте
Процедура Команда(Команда)

СсылкаОбъекта = СоздатьНаСервере();
//1.
ОткрытьФорму(«Документ.НашДокумент.Егоформа», Новый Стурктура(«Ключ»,СсылкаОбъекта)); // Через параметры мы передаем ссылку документа

&НаСервере
Функция ЗаполнитьДокументНаСервере()

// Используем метод создать

НовыйОбъект.Записать(); // Обязательно записываем

Возврат НовыйОбъект.Ссылка; //Возвращаем ссылку

Пример Задача из формы Номенклатуры открыть документ установка цен (с заполнение цен по умолчанию из РС.)

Док = ДанныеФормыВЗначение(ДанныеФормы, Тип(«ДокументОбъект.УстановкаЦенНоменклатуры»)); // Получаем объект из данных формы ИЛИ

// Заполняем реквизиты объекта или другие действия ********

Запрос = Новый Запрос;
Запрос.Текст = «ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ВидЦенПоУмочаниюДляУстанвкиЦенНоменклатуры.ТипЦены
|ИЗ
| РегистрСведений.ВидЦенПоУмочаниюДляУстанвкиЦенНоменклатуры КАК ВидЦенПоУмочаниюДляУстанвкиЦенНоменклатуры»;
Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
НовыйВидЦены = НовыйДок.ВидыЦен.Добавить();
НовыйВидЦены.ВидЦены = Выборка.ТипЦены;

НоваяСтрНоменклатуры = НовыйДок.Товары.Добавить();
НоваяСтрНоменклатуры.Номенклатура = Объект.Ссылка;
НоваяСтрНоменклатуры.ВидЦены = Выборка.ТипЦены;

КонецЦикла;
ЗначениеВДанныеФормы(НовыйДок,ДанныеФормы); // Кладем обратно в объект формы уже созданный документ

&НаКлиенте
Процедура СоздатьУстановкуЦен(Команда)

Форма = ПолучитьФорму(«Документ.УстановкаЦенНоменклатуры.Форма.ФормаДокумента»);
ДанныеФормы = Форма.Объект; // Получаем объект формы в переменную
ЗаполнитьДокументНаСервере(ДанныеФормы); // Заполняем документ на сервере
КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); // копируем наш объект в объект формы и далее открываем ее
Форма.Открыть();