Cisco packet tracer настройка коммутатора

Как настроить коммутаторы cisco 3 уровня, на примере cisco 3560

Как настроить коммутаторы cisco 3 уровня, на примере cisco 3560

настроить cisco 3560

Всем привет, сегодня хочу рассмотреть вопрос, о том как настроить коммутаторы cisco 3 уровня модели OSI, на примере cisco 3560. Напомню, что коммутаторы cisco 3 уровня не используются для выхода в интернет в качестве шлюза, а только маршрутизируют трафик между vlan в локальной сети. Для выхода в интернет cisco как и все вендоры предоставляет маршрутизатор? ниже представлена самая распространенная схема подключения.

Оборудование и схема сети

Предположим, что у меня коммутатор 3 уровня cisco 3560 24 порта, он выглядит как то вот так.

Он будет маршрутизировать трафик между vlan в моей локальной сети, и к нему допустим будут подключены 3 коммутатора 2 уровня модели OSI, уровня доступа, коммутаторы cisco 2960, а сам cisco 3560 будет выступать в качестве коммутатора уровня распределения. Напомню, что на втором уровне коммутируется трафик на основе mac адресов. Уровень доступа это куда подключаются конечные устройства, в нашем случае компьютеры, сервера или принтеры.. Ниже схема.

Что такое коммутатор второго уровня

Коммутатор второго уровня это железка работающая на втором уровне сетевой модели OSI

  • Коммутирует трафик на основе мак адресов
  • Используется в качестве уровня доступа
  • Служит для первичного сегментирования локальных сетей
  • Самая маленькая стоимость за порт/пользователь

В технической документации коммутатор второго уровня обозначает в виде вот такого значка

Что такое коммутатор третьего уровня

Коммутатор третьего уровня это железка работающая на третьем уровне модели OSI умеющая:

  • IP маршрутизация
  • Агрегирование коммутаторов уровня доступа
  • Использование в качестве коммутаторов уровня распределения
  • Высокая производительность

В технической документации коммутатор третьего уровня обозначает в виде вот такого значка

Помогать мне будет в создании тестового стенда программа симулятор сети, Cisco packet tracer 6.2. Скачать Cisco packet tracer 6.2, можно тут. Вот более детальная схема моего тестового полигона. В качестве ядра у меня cisco catalyst 3560, на нем два vlan: 2 и 3, со статическими ip адресами VLAN2 192.168.1.251 и VLAN3 192.168.2.251. Ниже два коммутатора уровня доступа, используются для организации VLAN и как аплинки. В локальной сети есть 4 компьютера, по два в каждом vlan. Нужно чтобы компьютер PC3 из vlan2 мог пинговать компьютер PC5 из vlan3.

С целью мы определились можно приступать. Напоминать, про то что такое vlan я не буду можете почитать тут.

Настройка cisco коммутатора 2 уровня

Настройка коммутатора второго уровня очень простая. Начнем настройку cisco catalyst 2960, как вы видите у меня компьютеры PC03 и PC04 подключены к Switch0, портам fa0/1 и fa0/2. По плану наш Switch0 должен иметь два vlan. Приступим к их созданию. Переходим в привилегированный режим и вводим команду

теперь в режим конфигурации

Создаем VLAN2 и VLAN3. Для этого пишем команду

задаем имя пусть так и будет VLAN2

Выходим из него

Аналогичным образом создаем VLAN3.

Теперь добавим интерфейс fa0/1 в vlan 2, а интерфейс fa0/2 в vlan 3. Пишем команду.

Говорим что порт будет работать в режиме доступа

switchport mode access

закидываем его в VLAN2

switchport access vlan 2

Теперь добавим fa0/2 в vlan 3.

switchport mode access

switchport access vlan 3

Теперь сохраним это все в памяти коммутатора командой

Настроим теперь trunk порт. В качестве trunk порта у меня будет гигабитный порт gig 0/1. Вводим команду для настройки порта gig 0/1.

Сделаем его режим trunk

И разрешим через транк нужные вланы

Сохраняем настройки. Все настройка коммутатора второго уровня почти закончена.

Теперь таким же методом настраивает коммутатор Switch1 и компьютеры PC5 в VLAN2 и PC6 в VLAN3. Все на втором уровне модели OSI мы закончили, переходим к 3 уровню.

Настройка cisco 3560

Настройка cisco 3560, будет производится следующим образом. так как наше ядро должно маршрутизировать внутренний локальный трафик, то мы должны создать такие же vlan, задать им ip адреса, так как они будут выступать в роли шлюзов по умолчанию, а так же trunk порты.

Начнем с транк портов, у нас это gig 0/1 и gig 0/2.

Читайте также:  Лучшие книги по linux

заходим в настройку интерфейса gig 0/1 и gig 0/2

int range gig 0/1-2

Попытаемся включить режим транка

switchport mode trunk

но в итоге вы получите вот такую подсказку: Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. Смысл ее в том, что вам сначала предлагают включить инкапсуляцию пакетов. Давайте настроим инкапсуляцию на cisco 3560.

Теперь укажем режим и разрешенные vlan

switchport mode trunk

switchport trunk allowed vlan 2,3

Сохраним настройки Cisco

Далее создадим vlan и назначим им ip адреса, которые будут выступать в роли шлюзов.

Назначим ip адреса для каждого из них, напомню для vlan 2 это 192.168.1.251/24, а для vlan 3 192.168.2.251/24

ip address 192.168.1.251 255.255.255.0

ip address 192.168.2.251 255.255.255.0

Теперь включим маршрутизацию между vlan, делается это командой

Проверка доступности

Открываем командную строку на PC3 и пробуем пропинговать его самого, шлюз и PC5. Вводим по очереди

Видим, что все отлично пингуется, значит связь есть.

Проверим теперь с PC3 соседа из VLAN3 PC6

Как видим, первый запрос потерялся, это происходит по тому, что перестроилась arp таблица, а дальше видим пакеты доходят до адресата.

Как видите настройка коммутатора второго уровня и третьего закончена. Задача выполнена. Вот как можно использовать коммутаторы cisco 3 уровня, и создать отличное ядро локальной сети. Если у вас есть вопросы и пожелания пишите в комментариях.

Категория: Cisco Packet Tracer / Автор: Артём

Чтобы настроить IP-адрес для интерфейса VLAN коммутатора необходимо выполнить следующие команды interface vlan 1 и ip address в CLI.

S1# conf t // переходим в режим глобальной конфигурации
S1(config)# interface vlan 1 // переходим в режим конфигурирования интерфейса
S1(config-if)# ip address 192.168.1.253 255.255.255.0 // присваиваем интерфейсу ip-адрес и маску сети
S1(config-if)# no shutdown // включаем интерфейс
S1(config-if)# ex // выходим из режима глобальной конфигурации
S1#

Результат выполнения команд interface vlan 1 и ip address.

Для достижения поставленной цели нам понадобится: в идеальном случае 1 коммутатор фирмы Cisco с поддержкой VLAN, 4 компьютера и 4 патчкорда; в более реальном и наиболее подходящем варианте, нам понадобится компьютер с установленным на него программным обеспечением Cisco Packet Tracer.

Если у нас есть реальное оборудование, то подключаем компьютеры к первым четырем портам коммутатора (далее считаем, что компьютер подключенный к порту 1 – это ПК1, к порту 2 – ПК2 и т.д.). Включаем коммутатор и компьютеры. Подключаемся с одного из компьютеров к коммутатору через консольный кабель. Наблюдаем консоль =)

Если же у нас нет реального оборудования, то запускаем Cisco Packet Tracer и собираем в нем следующую топологию (При сборке учитываем, что PC0 подключен к порту FasteEthernet0/1, PC1 к порту FasteEthernet0/2 и т.д).

После этого закройте окно настроек данного хоста и аналогичным образом сконфигурируйте 3 оставшихся. Задайте им следующие IP адреса: PC1 – 192.168.1.2/24, PC2 – 172.20.20.1/24, PC3 – 172.20.20.2/24.

Далее проверим, как применились введенные нами настройки. Для этого опять дважды щелкнем левой кнопкой мыши по одному их хостов, например по PC0. В открывшемся окне выбираем пункт Command Prompt и попадаем в окно консоли данного компьютера (данное действие аналогично тому, как если бы мы выполнили Пуск-Выполнить-cmd на реальном компьютере).

Почему это происходит? Хотя в данном случае все четыре компьютера находятся в одном vlan (как мы уже обсуждали ранее по умолчанию все порты коммутатора находятся в vlan 1), все они не могут видеть друг друга, так как находятся в разных подсетях. Компьютеры PC0 и PC1 находятся в подсети 192.168.1.0, а компьютеры PC2 и PC3 в подсети 172.20.20.0.

Возможно у вас возникает вопрос а зачем же вообще тогда нужны vlan, если компьютеры и так уже фактически взаимодействуют только парами, как мы хотели в начале статьи. Vlan нужны для того чтобы структурировать сети на коммутаторе и навести в них порядок, а так же для того чтобы было возможно осуществлять маршрутизацию между ними, ведь осуществить маршрутизацию между сетями в той конфигурации которую мы, на данный момент, получили в Packet Tracer будет довольно затруднительно.

Далее перейдем к настройке коммутатора. Откроем его консоль. Для того чтобы это выполнить в Packet Tracer дважды щелкните левой кнопкой мыши по коммутатору в рабочей области.

В результате выполнения команды на экране появится: номера vlan – первый столбец, название vlan — второй столбец, состояние vlan (работает он в данный момент или нет) – третий столбец, порты принадлежащие к данному vlan – четвертый столбец. Как мы видим по умолчанию на коммутаторе существует пять vlan-ов. Все порты коммутатора по умолчанию принадлежат vlan 1. Остальные четыре vlan являются служебными и используются не очень часто.

Читайте также:  Kb947821 что за обновление

Для реализации сети, которую мы запланировали сделать, создадим на коммутаторе еще два vlan. Для этого в привилегированном режиме выполните команду conft для перехода в режим конфигурации. Вводим команду vlan 2. Данной командой вы создадите на коммутаторе vlan с номером 2. Указатель ввода Switch(config)# изменится на Switch(config-vlan)# это свидетельствует о том, что вы конфигурируете уже не весь коммутатор в целом, а только отдельный vlan, в данном случае vlan номер 2. Если вы используете команду «vlan x», где x номер vlan, когда vlan x еще не создан на коммутаторе, то он будет автоматически создан и вы перейдете к его конфигурированию. Когда вы находитесь в режиме конфигурирования vlan, возможно изменение параметров выбранной виртуальной сети, например можно изменить ее имя с помощью команды name.

Для достижения поставленной в данном посте задачи, сконфигурируем vlan 2 следующим образом:

Разберем данную конфигурацию. Как уже говорилось ранее командой vlan 2, мы создаем на коммутаторе новый vlan с номером 2. Команда name subnet_192 присваивает имя subnet_192 виртуальной сети номер 2. Выполняя команду interface range fastEthernet 0/1-2 мы переходим к конфигурированию интерфейсов fastEthernet 0/1 и fastEthernet 0/2 коммутатора. Ключевое слово range в данной команде, указывает на то, что мы будем конфигурировать не один единственный порт, а целый диапазон портов, в принципе ее можно не использовать, но тогда последние три строки придется заменить на:

Команда switchport mode access конфигурирует выбранный порт коммутатора, как порт доступа (аксесс порт). Команда switchport access vlan 2 указывает, что данный порт является портом доступа для vlan номер 2.

Просмотрим результат конфигурирования выполнив уже знакомую нам команду show vlan br еще раз:

Как легко заметить из результата выполнения данной команды, у нас на коммутаторе появился еще один vlan с номером 2 и именем subnet_192, портами доступа которого являются fastEthernet 0/1 и fastEthernet 0/2.

Далее аналогичным образом создадим vlan 3 с именем subnet_172, и сделаем его портами доступа интерфейсы fastEthernet 0/3 и fastEthernet 0/4. Результат должен получиться следующим:

В принципе уже все готово, наша сеть уже настроена, так как мы и планировали в начале поста. Осталось лишь ее немного протестировать. Перейдите в консоль компьютера PC 0. Пропингуйте с него остальные 3 компьютера сети. Как вы можете заметить, ничего не изменилось, компьютер PC1 доступен, а компьютеры PC2 и PC3 по прежнему не доступны. Раз ничего не изменилось, то как же мы можем быть уверены, что наша конфигурация vlan действительно работает? Для этого пойдем на маленькую хитрость — зададим компьютерам PC2 и PC3 IP адреса из сети 192.168.1.0/24. Например 192.168.1.3 и 192.168.1.4. И теперь снова попробуем пропинговать с компьютера PC0 остальные компьютеры сети. Как видим снова ничего не изменилось, хотя все четыре компьютера теоретически должны находится в одной подсети 192.168.1.0/24 и видеть друг друга, на практике они находятся в разных виртуальных локальных сетях и поэтому не могут взаимодействовать между собой. Если есть желание проверить это еще раз, то перейдите на компьютер PC 2 и пропингуйте остальные компьютеры. Доступным будет только PC3, так как они вместе находятся в одном vlan номер 3.

На сегодня это все. В следующем посте мы обсудим как передавать vlan между коммутаторами, и как реализовать данный функционал на коммутаторах фирмы Cisco.

Выше мы разобрали как настроить порты доступа для vlan на отдельных коммутаторах фирмы Cisco, это конечно хорошо, но этого мало, ведь мы пока еще не умеем передавать данные vlan-ов между коммутаторами. В данном посте мы рассмотрим этот вопрос и научимся настраивать транковые порты (trunk).

Пусть у нас имеется два коммутатора фирмы Cisco, на каждом из этих коммутаторов подняты vlan с номерами 2 и 3. Порт FastEth 0/1 является портом доступа vlan 2, а порт FastEth 0/2 портом доступа vlan 3, одинаково на обоих коммутаторах. К порту FastEth 0/1 первого коммутатора подключен компьютер с IP адресом 192.168.1.1/24, к порту FastEth 0/2 компьютер с IP адресом 192.168.1.101/24. Аналогичным образом ко второму коммутатору подключены компьютеры с IP адресами 192.168.1.2/24 и 192.168.1.102/24 Данная конфигурация изображена на рисунке.

Читайте также:  Инсталляция grohe не набирает воду

Соберем данную сеть в Packet Tracer. Зададим IP адреса в соответствии с рисунком. Оба коммутатора настроим используя следующие команды:

Получившаяся схема будет иметь приблизительно следующий вид:

В полученной схеме, ни один из компьютеров не должен видеть другие компьютеры. Так как компьютеры, находящиеся в vlan с одинаковыми номерами находятся на разных коммутаторах не связанных между собой. На данном этапе процесс подготовки завершен, и мы перейдем непосредственно к рассмотрению вопроса передачи данных vlan между коммутаторами.

Как мы уже обсуждали ранее, решить эту задачу можно двумя способами: используя порты доступа или используя транковые порты(trunk). Рассмотри оба этих способа по очереди.

Сначала рассмотрим вариант использования портов доступа для соединения коммутаторов между собой. Для этого на каждом из коммутаторов сконфигурируем интерфейсы FastEth 0/3 и FastEth 0/4 как порты доступа, порт 0/3 отнесем к vlan 2, а порт 0/4 к vlan 3. Для этого на коммутаторах выполним следующие команды:

Для проверки конфигурации выполним команду show vlan brief, ее результат должен быть следующим.

Для передачи трафика сразу нескольких vlan-ов по одной линии между коммутаторами используются специальные транковые порты (trunk). Для того чтобы настроить данные порты на коммутаторах выполним следующие команды в режиме конфигурирования (в роли trunk портов будут выступать интерфейсы FastEthernet0/3):

Разберем назначение данных команд. С помощью команды "interface FastEthernet0/3" переходим к конфигурированию интерфейса FastEthernet0/3. Выполняя команду "switchport mode trunk" вы переводите данный порт в режим работы в виде транка (то есть режим позволяющий передавать через себя трафик нескольких vlan-ов), данная команда автоматически отменяет введенную нами в конфигурацию интерфейса FastEthernet0/3 команду "switchport mode access". Команда "no switchport access vlan 2" отменяет примененные нами ранее настройки для портов доступа на интерфейсе FastEthernet0/3 (если вы конфигурируете новый интерфейс, то выполнять данную команду не нужно).

После того, как данная конфигурация вбита в коммутатор, настало время изменить физическую конфигурацию нашей сети в PacketTracer. Так как мы настраиваем вариант в котором все vlan между коммутаторами будут передаваться через один линк через порты FastEthernet0/3, то мы смело можем удалить соединение между портами FastEthernet0/4. В таком случае схема примет вид:

По идее все уже должно работать, и оба vlan, настроенные на коммутаторах, должны ходить между ними через один единственный линк. Проверим это. Для этого опять же пропингуем с компьютера PC0 остальные компьютеры сети. Если все настроено верно, то компьютер PC 2 должен стать доступен, а все остальные компьютеры нет.

Используя на интерфейсе команду switchport mode trunk мы перевели его в транковый режим, в котором интерфейс пропускает через себя все существующие на коммутаторе vlan, но иногда необходимо передавать через данный интерфейс не все vlan, а лишь некоторые, как это показано на рисунке.

Перейдем к настройке коммутаторов. Создадим на каждом из них еще по одному vlan с номером 4. Добавим в данный vlan в качестве портов доступа интерфейсы FastEthernet0/4. Проверим полученную конфигурацию. Если все сделано верно то с PC 0 должен пинговаться только PC2, c PC 4 только PC5, а с PC 1 только PC3. То есть трафик всех vlan свободно ходит между коммутаторами, нарушим эту идиллию и разрешим между коммутаторами только трафик vlan 2 и 3. Для этого на обоих коммутаторов выполним команды:

Как вы наверное уже догадались команда "switchport trunk allowed vlan 2-3" указывает транковому порту коммутатора, какие vlan ему пропускать через себя. После того как вы выполните эту команду компьютер PC4 должен перестать видеть компьютер PC5. Команда "switchport trunk allowed vlan" при своем использовании каждый раз задает разрешенные порты заново, то есть если вы выполните команду switchport trunk allowed vlan 5, а потом выполните команду switchport trunk allowed vlan 6, то разрешенным окажется только vlan номер 6. Для добавления vlan к списку разрешенных служит команда switchport trunk allowed vlan add x, где x номер добавляемого vlan. Для удаления vlan из списка разрешенных используется команда switchport trunk allowed vlan remove x, где x номер удаляемого vlan. Для просмотра информации о настроенных на коммутаторе транках служит команда show int trunk.

Думаю это все, что для начала нужно знать о настройки vlan на коммутаторах фирмы Cisco. Теперь вы можете хорошенько потренироваться в их настройке собирая различные конфигурации в Packet Tracer.