Горизонтальные полосы при просмотре видео на ютуб

@SupportTech , здравствуйте. Клиентом пикабу не пользуюсь, т.к лично мне удобнее просматривать ленты в мобильной версии сайта. Просмотр работает как и положено, видео открывается. Но при просмотре в полноэкранном режиме, внизу видео появляется белая полоса.

Если просмотреть картинку, это можно увидеть. Глюк проявляется только в мобильной версии. В полном режиме, или новой вкладке напрямую, такой ошибки нет.

Устройство Blackview BV8000Pro, браузер chrome 67.0.3396.87 , android 7.0.0, bv8000pro build/NRD90M

Думаю, многие из вас обращали внимание на то, что при просмотре видео часть экрана занимают черные полосы. Происходит это потому, что соотношение сторон кадра видео не совпадают с соотношением сторон экрана.

Чтобы задействовать весь экран и убрать полосы нужно обрезать часть изображения. В большинстве случаев, удаление горизонтальных полос сверху и снизу путем обрезки кадра слева и справа не ухудшает восприятие. Зато экран используется на все 100%!

Итак, что нужно сделать:

  1. Установить расширение для Chrome Video Plus. Данное расширение сделано для того, чтобы вписывать изображение, в котором черные полосы есть со всех сторон. Это не совсем то, что нам нужно. Зато там есть возможность переписать стили обработки изображения для разных сайтов.
  2. Для этого заходим в настройки:

  1. В этом поле выделяем все:

и вставляем этот код:

.html5-video-container <
height: 100% !important;
>

video.html5-main-video <
height: 100% !important;
object-fit: cover !important;
top: 0 !important;
left: 0 !important;
>

Теперь можно протестировать, что у нас получилось. Нужно найти какое-нибудь широкоэкранное видео, например, это, и посмотреть, вписывается оно в ваш экран, или нет.

Данная настройка работает по умолчанию для любого видео в Youtube, в том числе при просмотре на весь экран, о чем сигнализирует галочка на значке расширения. Но вы всегда можете ее выключить, кликнув на значок расширения.

Читайте также:  Как подключить флешку к смартфону xiaomi

sudo apt-get install vdpau-va-driver
sudo kate /etc/environment
добавь строчку LIBVA_DRIVER_NAME="vdpau"
Далее в VLC

Настройки → Ввод и кодеки → Использовать видеоускоритель включаем.

В настройках flash выключить (или отключить) аппаратное ускорение
ПКМ на flash-объекте -> Параметры -> Аппаратное ускорение

По идее, нужно включить вертикальную синхронизацию в настройках nvidia.
В vlc использовать вывод через xv

Посмотри в OpenGL Settings

По моему в xserver xvideo settings, sync to v blank. как то так называется.
В vlc поставили вывод через xv?

Не, это не то.
Сейчас компа рядом нет, попозже напишу куда там нужно тыкнуть.

А деинтерлейсинг — это не то?
*Очень рекомендую XBMC! Пересел на него как раз с VLC. А для беглого просмотра достаточно православного Kaffein.

Нет. Получается только немножко хуже.
Для меня оптимальный вариант настройки по умолчанию и с отключённым видеоускорителем.

у меня такое было на движке XRender (сейчас в KDE вроде по умолчанию) переключил на OpenGL всё стало нормально.

Установил XBMC.Он по воспроизведению видео ни чем не отличается от VLC. В нём точно-такие же полосы, что и в VLC.

Немного освоился в XBMC. Действительно, XBMC воспроизводить видео чем VLC. Получилось XBMC настроить так, чтобы не было полос и рассыпание картинки на пиксели.

Вроде бы вывод "через openGL" помогает.
Vlc > Инструменты > настройки > видео > вывод > Вывод видео через OpenGL GLX (XCB)

.kde/share/config/kwinrc
UnredirectFullscreen=true
Избавило от "прозрачных мерцающих полос" в видеоплеерах, флэше и играх в режиме Full Screen. При просмотре в окошках — нет.
PS: если важно, то 12.04, кде 4.11.2, драйвер нвидиа 319.60.
В nvidia-settings Sync to VBlank — вкл.; в Эфектах раб.стола Vsync — автоматически.

Читайте также:  Как поменять язык на телевизоре jvc

upd /etc/profile.d/Tearing.sh
export KWIN_TRIPLE_BUFFER=1
# chmod +x /etc/profile.d/Tearing.sh
reboot

Просто поменяй стиль оформления рабочего стола в меню "Цветовая схема"

Друзья мои у меня мерцающие горизонтальные полосы появляются при просмотре мультиков, фильмов и при играх когда вращаешь камерой, ноутбук мой подключен к телику 46′ по hdmi, разрешение у ноутбука 1366*768 а у телека 1920*1080, при подключении на телек так же выводиться 1366*768 так как это максимальное разрешение ноутбука моего. Пробовал менять кабеля, драйвера, отсоединял сетевой фильтр китайский этот, т.к. многие на них жаловались что там заземление фонит, кто то усы заземляющие отгинал и говорил помогало, но у меня полосы так и остались. Думал уже телек фонит, интерференция или еще что то там, т.к. в него много проводов напихано. Но вот интересный факт: на самом ноутбуке полос нет, только когда к телеку подключаешь появляются полосы как на ноутбуке, так и на телеке. У меня еще PS3 есть и системный блок (игровой комп), которые также подключены к телеку по hdmi, так вот PS3 — все отлично никаких полос, Системный блок выводит изображение через видеокарту GTX 660 — тоже все хорошо, игры на максималках, мультики, фильмы — никаких горизонтальных полос . На что тогда грешить то? Я так думаю может что то с синхронизацией разрешения ноутбука и телека или видеокарта где то грешит, не пойму пока. У ноутбука 2 карты Family HD Graphics и gt 540М. Вот такой нюанс друзья. Не знаю помог кому ли? Сам также прислушаюсь к вашим решениям этой проблемы. Всем спасибо.

Советую смотреть видео в XBMC.
Настрой так.
Включи аппаратное ускорение (VDPAU)
Отключи аппаратное ускорение (VAAPI)
Отключи преобразование цветов VDPAU
В противном случае видео при воспроизведение может притормаживать на секунду.

Оцените статью
Добавить комментарий

Adblock detector