Tp link tl wr703n настройка

ВАЖНО

До обновления прошивки рекомендуется освободить WAN порт роутера (отключить кабель провайдера) и перезагрузить сам роутер.

Неправильно выбранная прошивка может повредить ваше устройство и сделать вашу гарантию недействительной.

НЕ выключайте устройство во время обновления. Важно понимать, что прерванный процесс перепрошивки выведет ваше устройство из строя.

НЕ выполняйте обновление программного обеспечения по беспроводной сети. Пользуйтесь только кабельным подключением Компьютер — LAN порт роутера. Если на этом компьютере также есть wi-fi подключение, его в обязательном порядке следует отключить.

Все выше перечисленные моменты могут стать причиной отказа в гарантийном ремонте, поэтому если вы не уверены, что самостоятельно справитесь с обновлением ПО — вы можете обратиться в авторизованные сервисные центры. Если гарантийный период для роутера не истёк — обновление ПО будет бесплатным.

1. Прошивка TP-LINK TL-WR703N

Подключаем к сети, набираем в браузере 192.168.1.1. В меню на китайском, жмём последнюю строку.

Кликаем мышкой из раскрывшегося меню, жмём третью строчку. Появится окно прошивки.

Нажимаем кнопку справа от поля ввода, выбираем файл прошивки. Жмем на кнопку внизу слева.

Подключаемся телнетом на адресс 192.168.1.1.
В командной строке вводим команду

passwd

Далее вводим пароль и его подтверждение.

Открываем Putty, вводим 192.168.1.1
логин: root пароль :тот что ввели выше

Устанавливаем свои сетевые настройки:

vi /etc/config/network

Переводим интерфейс в режим редактирования [Shift]-I. Дополняем файл конфигурации

config interface ‘lan’

option ifname ‘eth0’

option type ‘bridge’

option proto ‘static’

option ipaddr ‘192.168.1.1’

option netmask ‘255.255.255.0’

option gateway ‘192.168.1.232’

list dns ‘80.237.52.99’

list dns ‘8.8.8.8’

Сохраняем [ESC][ESC] шифт Z Z.
Если сохранение произошло ,внизу появляется командная строка.

Eще нужно добавить строку в /etc/sysupgrade.conf для предотвращения перезаписи ваших конфигов при ребуте.

echo «/etc/config/» >> /etc/sysupgrade.conf

Перезапускам сетевые интерфейсы роутера командой:

/etc/init.d/network restart

Проверяем, сетевые настройки, есть ли подключение к Интернету:

ping ya.ru

Можно запустить у себя в сети web-сервер и скачать туда определеннй набор файлов
и произвести обновление с него.

vi /etc/opkg.conf

src/gz barrier_breaker http://192.168.1.246/wrt/packages

dest root /

dest ram /tmp

lists_dir ext /var/opkg-lists

option overlay_root /overlay

Если все ОК, подгружаем нужные компоненты:

opkg update

opkg install kmod-usb-uhci opkg kmod-usb-ohci kmod-usb-storage block-mount kmod-fs-ext4 kmod-fs-vfat kmod-nls-cp437 kmod-nls-cp850 kmod-nls-iso8859-1 kmod-nls-iso8859-15 kmod-scsi-core e2fsprogs fdisk

opkg install kmod-usb-storage kmod-fs-ext4 block-mount
opkg install fdisk
opkg install e2fsprogs

Теперь все готово для подготовки Флешки к форматированию. Вставляем флешку, в /dev должны появиться устройства типа /dev/sda1.

fdisk /dev/sda1

Выполняем следующие операции:

Command (m for help): m (Показать все действия)

Command (m for help): p (Показать разделы)

Command (m for help): d (Удалить разделы)

Command (m for help): n (Новый раздел)

Command (m for help): w (Записать)

Далее — все по-умолчанию, ну или на свое усмотрение, в конце не забываем

Command (m for help): a (make partition bootable) RETURN

Partition number (1-4): 1

Command (m for help): w (Записать)

Раздел создан, форматируем его:

mkfs.ext4 /dev/sda1

Теперь монтируем в /mnt/usb и копируем все необходимое:

Читайте также:  3241 Билайн как отключить

mkdir -p /mnt/usb

mount /dev/sda1 /mnt/usb

tar -C /overlay -cvf — . | tar -C /mnt/usb -xvf —

Теперь правим /etc/config/fstab:

vi /etc/config/fstab

Переводим интерфейс в режим редактирования [Shift]-I. Дополняем файл конфигурации
Правим секцию ‘config mount’:

config mount

option target /overlay

option device /dev/sda1

option fstype ext4

option options rw,sync

option enabled 1

option enabled_fsck 0

Сохраняем [ESC][ESC] шифт Z Z.

Сохраняем, перезагружаемся, проверяем:

reboot

Filesystem Size Used Available Use% Mounted on
rootfs 3.7G 131.0M 3.4G 4% /
/dev/root 1.5M 1.5M 0 100% /rom
tmpfs 14.3M 1.7M 12.5M 12% /tmp
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 3.7G 131.0M 3.4G 4% /overlay
overlayfs:/overlay 3.7G 131.0M 3.4G 4% /

Установливаем вебинтерфейс LYCI.

opkg update

opkg install luci luci-i18n-russian

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

Зададим порт по-умолчанию

vi /etc/config/uhttpd

list listen_http 0.0.0.0:81

Установливаем файловый менеджер MC.

opkg update

opkg install mc

2. Устанавливаем FTP-сервер

Создадим группу админов сервера:

echo web:x:101: >> /etc/group

Создадим домашнюю директорию для файлов и пользователя, который будет владеть этой директорией:

echo wwwadmin:*:101:101:wwwadmin:/home/www:/bin/ash >> /etc / passwd

mkdir /home

mkdir /home/www

chgrp web /home/www

chown wwwadmin /home/www

Зададим пароль для пользователя wwwadmin:

passwd wwwadmin

Установим pure-ftpd — быстрый и лёгкий FTP-сервер

opkg update

opkg install pure-ftpd

Выберем отдельный лог отредактировав следующие строки:

vi /etc/config/pure-ftpd

option syslogfacility ‘none’

option altlog ‘stats:/var/log/pureftpd.log’

option enabled ‘1’

/etc/init.d/pure-ftpd start

/etc/init.d/pure-ftpd enable

Зайдём в веб-админку на вкладку Система -> Загрузка и отметим pure-ftpd для автоматического запуска.

3. Устанавливаем веб-сервер

Используем тот же логин и пароль что и для FTP

Установим веб-сервер lighttpd с нужными плагинами:

opkg update

opkg install lighttpd lighttpd-mod-cgi lighttpd-mod-access lighttpd-mod-redirect

opkg install libsqlite3 php5 php5-cli php5-cgi php5-mod-pdo php5-mod-sqlite php5-mod-gd php5-mod-session php5-mod-sqlite3 php5-mod-pdo php5-mod-json php5-mod-pdo-sqlite

vi /etc/lighttpd/lighttpd.conf

Подключим нужные нам плагины:

server.modules = ( «mod_cgi», «mod_access», «mod_redirect» )

Установим директорию для документов:

server.document-root = «/home/www»

Зададим имена документов по-умолчанию:

index-file.names = ( «index.htm», «index.php» )

Зададим порт о-умолчанию:

server.port = 80

Укажем CGI-обработчик для PHP:

cgi.assign = ( «.php» => «/usr/bin/php-cgi» )

Желательно указать UID и GID для сервера, чтобы он не работал с правами суперпользователя:

server.username = «wwwadmin»

server.groupname = «web»

Настроим PHP, отредактировав файл

vi /etc/php.ini

Подключим нужные модули, раскоментировав соответствующие строки:

extension=pdo.so

extension=gd.so

extension=pdo_sqlite.so

extension=session.so

extension=sqlite3.so

extension=sqlite.so

Изменим параметр doc_root на пустую строку, иначе интерпретатор будет искать скрипты не в том месте:

doc_root =

date.timezone = Asia/Krasnoyarsk

Чтобы избежать ошибки: Cannot send session cache limiter — headers already sent

нужно включить буферизацию вывода для всех файлов в php.ini

output_buffering = On

Изменим параметр date.timezone для установки часового пояса в файлах /etc/php.ini и /etc/php-cli.ini:

opkg update

opkg install zoneinfo-core

opkg install zoneinfo-asia

/etc/init.d/lighttpd start

/etc/init.d/lighttpd enable

Создадим в vi /home/srv/www файл index.php с таким содержимым:

Откроем 192.168.0.1/test.php. Если всё прошло удачно, увидим таблицу с настройками PHP:
Перейдём на вкладку Services веб-админки и разрешим автоматический запуск lighttpd.

4. Устанавливаем драйвера для Arduino

Установим драйвера для USB2Serial FT232:

opkg update

opkg install kmod-usb-serial-ftdi kmod-usb-serial-option

5. Конфигуририруем COM порт

Устанавливаем утилиту конфигурирования COM порта:

opkg install coreutils-stty

6. Другие прошивки на TP-LINK WR703N

Переход с DD-WRT на оригинальную китайскую: wr703nv1_webrevert.bin

Важно с прошивки DD-WRT на любую другую можно только через оригинальную

7. Прошивка из сети

Роутер должен быть настроен для выхода в интернет.

cd /tmp

‘wget’ http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

mtd -r write openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin firmware

Читайте также:  Defender hollywood 35 схема подключения колонок

После ввода последней команды начинается процесс прошивки:

Unlocking firmware …

Writing from openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin to firmware … [w]

Дожидаемся окончания прошивки. Благодаря ключу -r роутер перезагрузится автоматически.

Rebooting …

8. Основные команды opkg

1. opkg list — команда выдает список пакетов, которые можно установить в настоящий момент.
2. opkg list-installed — команда выдает список уже установленных пакетов
3. opkg update — команда скачивает список пакетов, которые могут быть установлены. Рекомендуется всегда выполнять эту команду перед установкой пакета и при других «манипуляциях» с пакетами.
4. opkg upgrade — команда обновляет установленные пакеты, если есть обновления.
5. opkg install — команда устанавливает пакет включая пакеты, от которых устанавливаемый пакет зависит. Например «opkg install mc» установит Midnight Commander.
6. opkg remove — команда удалит установленный ранее пакет.

9. TP-Link penWRT reset (сброс настроек)

Для сброса на OpenWRT по умолчанию:
1. Выключаем и включаем маршрутизатор
2. Когда начнет мигать диод SYS, зажимаем и удерживаем QSS пока SYS не начнет быстро мигать
3. Заходим через терминал на маршрутизатор командой telnet 192.168.1.1 (вход без пароля).
4. Вводим команду mtd -r erase rootfs_data
После чего, немного подождав, маршрутизатор сам перезагрузится.

Правила перепечатки

Понравилась статья?
Лучшей наградой для меня будет ваш комментарий !

Блог о полезных программах и вещах

Плюсы

среда, 30 ноября 2011 г.

Настройка 3G маршрутизатора TL-WR703N

Выбираем "режиме 3 G маршрутизатора", нажмаем кнопку "Далее". Выберите регион "Китай", указывать мобильного провайдера не обязательно: "China Telecom", "China Mobile" и "China Unicom" (в соответствии с вашим Интернет-провайдером), остальные значения по умолчанию не изменяются.

Примечание: TL-WR703N по умолчанию имеет встроенные настройки для операторов China Telecom, China Mobile и China Unicom. Нажмите "Next", чтобы установить защиту беспроводной сети.

SSID номер: Это определяет имя беспроводной сети может быть изменено.
Канал: 1-13.
Режим: маршрутизатор, который используется для выбора режима работы, выбор пропускной способности 802.11b в режиме с 11M, 54M пропускной способности 802.11g режиме 300M, 802.11n режиме 802.11b / g. смешанном режиме и 802.11b / G / N смешанном режиме.
Группа Величина: Авто, 20 МГц и 40 МГц.
Максимальная скорость передачи данных: по умолчанию.
Шифрование: Чтобы обеспечить Вашу беспроводную сеть от несанкционированного доступа со стороны, рекомендуется установить беспроводное шифрование, рекомендуется метод шифрования WPA-PSK/WPA2-PSK.

В списке беспроводных сетей должна появиться ваша сеть.

После завершения установки, нажмите кнопку "Далее", чтобы перезагрузить маршрутизатор, подождите 1-3 минуты, проверьте устройство "работает" — "3G", вы можете видеть IP-адрес маршрутизатора имеет доступ к необходимым параметрам, таким как Интернет, маршрутизатор коммутируемого было успешно, как показано, и вы можете нормально выйти в Интернет.

Light and dark — a subtle interweaving of the fringes of consciousness…

TP-Link TL-WR703N — Unbrick

Заказал из Китая миниатюрный роутер TP-Link TL-WR703N. Доставки ждал совсем «недолго», всего каких-то 3 месяца, в очередной раз «спасибо» нашей почте. В конце концов роутер приехал. Эта модель рассчитана только на внутренний рынок Китая, поэтому кроме китайского интерфейса в веб-админке другого нет. Что ж, не беда, я изначально планировал поставить на эту железку прошивку OpenWrt, благо поддержка в OpenWrt Wiki заявлена.

Прочитал, как мне казалось, внимательно страничку в их Wiki, убедился (как оказалось — хреново), что версия моей прошивки 1.6, скачал последнюю со страницы Wiki ‘squashfs-factory.bin’ и прошил. Все прекрасно прошилось и казалось бы ничто не предвещало беды, однако, LAN-порт стал недоступен, а Wi-Fi в OpenWrt по умолчанию отключен. Прекрасно! Таким образом, в Failsafe mode я войти не мог, как не пытался.

Читайте также:  Как записать звонок в whatsapp

Оказывается, прошивка на моем устройстве была версии 1.7 с новым U-boot, не смотря на то, что на наклейке сзади корпуса четко было указано — 1.6. Версию 1.7 поддерживает только прошивка из trunk’а, ее то и следовало сразу прошить. Ничего не остается, как разобрать роутер и подпаяться к serial.

Приступаем к разборке:

Расчехляем паяльник и подпаиваемся к GND, RX и TX:

Вроде все готово, теперь остается подключить 3.3V USB to TTL serial adapter, в моем случае на чипе pl2303. В качестве serial terminal я выбрал Minicom, хотя под OS X есть терминалы и с развесистым GUI, к примеру, ZTerm, но это все дело вкуса и привычки. Параметры подключения: 115200/8/N/1/XON-XOFF.

Через 1-2 секунды вы увидите строку ‘Autobooting in 1 seconds’, в это время нужно быстро послать команду ‘tpl’, это позволит нам войти в U-boot rescue mode, при этом мы должны увидеть строку приглашения ‘hornet’:

Теперь нам необходимо поднять TFTP Server в общей с нашим препарируемым роутером локальной сети. Я для этих целей выбрал tftpd-hpa, который и установил на своем домашнем сервере:

apt-get install tftpd-hpa

Настраивать там особо нечего, поэтому акцентировать на этом свое внимание я не буду. Скачиваем последнюю прошивку из trunk‘а для нашего роутера (openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin) в каталог нашего tftp-сервера.

Настроим IP-адрес роутера и укажем IP-адрес tftp-сервера, для примера:

setenv ipaddr 192.168.1.111
setenv serverip 192.168.1.5

Приступаем к заливке прошивки:

tftpboot 0x81000000 openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

erase 0x9f020000 +0x3c0000

cp.b 0x81000000 0x9f020000 0x3c0000

Все, мы прошились. Устанавливаем пароль root’у на этом этапе, либо при первой загрузке придется зайти через telnet, установить пароль, и только после этого можно будет заходить на устройство по ssh. Подключаемся к LAN-порту, перезагружаем устройство и убеждаемся, что теперь сеть работает.

На следующем этапе мы настроим сеть. Заходим на устройство и правим:

ssh root@192.168.1.1
vi /etc/config/network

Указываем наш IP, шлюз и DNS-сервер, к примеру:

option ipaddr ‘192.168.1.111’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.1’
option dns ‘192.168.1.1’

Опускаем и поднимаем линк:

Теперь я предлагаю поставить веб-админку LuCI, чтобы конфигрурировать дальше было проще и быстрее:

opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

Вот что из этого получилось:

Ну и последнее, что я предлагаю сделать, так это настроить простой вариант сброса пользовательских настроек и установленных пакетов. Для этого поставим пакет ‘restorefactory’:

opkg install restorefactory

vi /etc/config/system
config restorefactory
option button reset
option action pressed
option timeout 5

Теперь, в случае внештатной ситуации, можно просто зажать кнопку ‘Reset’ на 5 секунд и вы получите вновь ненастроенный девайс без пользовательских настроек и пакетов. В ином случае вам придется вручную вводить устройство в Failsafe mode. Для этого после включения нужно подождать около 10-12 секунд (пока светодиод не начнет моргать) и сразу же после этого зажать кнопку ‘Reset’ на 1-2 секунды, светодиод начнет быстро моргать, таким образом вы войдете в Failsafe mode. Заходите по telnet:

На этом все. Надеюсь это кому-либо будет полезно. Удачи!